Geeetech i3, USB technical issue

Post Reply
Posts: 1
Joined: Fri Jul 08, 2022 8:26 pm

Geeetech i3, USB technical issue

Post by katakuri » Fri Jul 08, 2022 8:37 pm

So, yesterday i was given a Geeetech i3 printer by a friend.

History ont the printer is he got the kit about 3 years ago and the heated bed never worked, Geeetech replaced the motherboard it has a GT2560 and still nothing, So its been sat on a shelf since.

So i got the printer powered it up saw that it said error for the temp for the bed, inspected th is and the Thermister was not connected on 1 leg. Replaced this and now the bed heats up.

Next issue, i tried to move all the axis's manually and only the Y axis would move using the lcd. Moved the stepper driver (A4988) from the Y to the X and now the X works, so i have ordered replacement steppers which arrive today hopefully

Confirm the hotend works but extruder is not moving, can manually push fillament through so no issues here.

The problem

I thought i would try and connect the printer to Octopi and see if it communicated, however as soon is i turned on the printers power it smoked the PI and the usb cable that was connected. So how would i go about diagnosing why the printer is basicaly either shorting out or passing way too much power to the USB ?

As long as the printer is not powered i can communicate with it over the USB, i also tried it with a USB hub and it blew that too soon as it powered up along with another cable fml...

Post all this, I have now flashed marlin 2.0 bug fix onto the motherboard, just waiting on the stepper drives to arrive to see if it all works, if it does maybe this printer will be a SDcard only printer?

Post Reply